Alihkan semua DNS ke PiHole dengan Router MikroTik Hairpin NAT

Ketemu lagi dengan saya Een Pahlefi, dalam kasus kali ini kita akan semua membelokan traffik dns yang berasal dari request client ke server pi-hole.

Kita perlu bantuan hairpin NAT agar semua nya bisa berjalan dengan lancar, baiklah langsung saja













/ip firewall nat
add action=dst-nat chain=dstnat dst-address=!192.168.22.48 dst-port=53 protocol=udp src-address=!192.168.22.48 to-addresses=192.168.22.48 to-ports=53
add action=dst-nat chain=dstnat dst-address=!192.168.22.48 dst-port=53 protocol=tcp src-address=!192.168.22.48 to-addresses=192.168.22.48 to-ports=53
add action=masquerade chain=srcnat dst-address=192.168.22.48 dst-port=53 protocol=udp src-address=192.168.22.0/24
add action=masquerade chain=srcnat dst-address=192.168.22.48 dst-port=53 protocol=tcp src-address=192.168.22.0/24

Kekurangan script diatas adalah, di karenakan kita menggunakan nat, otomatis semua header request dns client akan diwakili oleh alamat ip address router yaitu 192.168.22.1

Jadi bijaklah dalam penggunaan hairpin NAT ini.

Referensi : disini

Semoga Bermanfaat.
Penulis : Een Pahlefi,S.Kom

Subscribe to receive free email updates: