VLAN dengan Switch-chip pada Routerboard

Halo ketemu lagi dengan saya Een Pahlefi, Kali ini saya akan mencoba membagikan dokumentasi hasil belajar saya mengenai VLAN.

Karena keterbatasan perangkat, saya mempunyai bahan sebagai berikut.

1. Router1 sebagai intervlan
2. Router2 sebagai vlan dengan fitur switch - chip.

Pada hakikat nya Routerboard fungsi nya adalah sebagai router, akan tetapi dia juga bisa di fungsikan sebagai switching.



R1
/ip address
add address=192.168.10.1/30 interface=vlan10 network=192.168.10.0
add address=192.168.20.1/30 interface=vlan20 network=192.168.20.0
add address=192.168.30.1/30 interface=ether5-trunk network=192.168.30.0

/interface vlan
add interface=ether5-trunk name=vlan10 vlan-id=10
add interface=ether5-trunk name=vlan20 vlan-id=20


R2
/ip address
add address=192.168.30.2/30 interface=bridge1 network=192.168.30.0

/ip route
add distance=1 gateway=192.168.30.1

/interface bridge
add name=bridge1
/interface bridge port
add bridge=bridge1 interface=ether1-trunk
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3


/interface ethernet switch port
set 0 vlan-header=add-if-missing vlan-mode=secure
set 1 default-vlan-id=10 vlan-header=always-strip vlan-mode=secure
set 2 default-vlan-id=20 vlan-header=always-strip vlan-mode=secure


/interface ethernet switch vlan
add ports=ether1-trunk,ether2,switch1-cpu switch=switch1 vlan-id=10
add ports=ether1-trunk,switch1-cpu switch=switch1
add ports=ether1-trunk,ether3,switch1-cpu switch=switch1 vlan-id=20

Penjelasan Configurasi :

Di Router1 saya pasang IP 192.168.30.1/30, kemudian di Router2 saya pasang IP 192.168.30.2/30.

Kemudian saya pasang tambahkan ether1-trunk dan switch1 CPU agar R2 bisa terhubung, dan tak ketinggalan default route di R2 saya isi dengan gateway 192.168.30.1,

Kesimpulan nya adalah walaupun ketika saya berada di VLAN10 maupun VLAN20, saya tetap bisa mengakses R2 dengan mudah :D


leave-as-is : paket data tidak ada perubahan ketika keluar dari port
always-strip : akan menghilangkan VLan Header pada paket data
add-if-missing : akan menambahkan VLan Header pada paket data



Subscribe to receive free email updates: