Routing OSPF + MPLS Dasar

Berjumpa lagi dengan saya Een Pahlefi, kalo kemarin saya menulis tentang OSPF, kali ini saya akan menulis tentang MPLS, dalam praktik nya untuk mengconfigurasi MPLS di butuhkan setidak nya 3 router, kemudian ke 3 router tadi sudah harus menjalankan routing protokol RIP atau OSPF dimana semua router harus sudah terhubung satu dengan yang lain nya.


R1

/ip address
add address=192.168.5.1/30 interface=ether5 network=192.168.5.0
add address=192.168.10.1/30 interface=ether1 network=192.168.10.0
add address=192.168.20.1/30 interface=ether2 network=192.168.20.0
add address=1.1.1.1 interface=lo network=1.1.1.1

/interface bridge
add name=lo protocol-mode=none

/routing ospf instance
set [ find default=yes ] router-id=1.1.1.1
/routing ospf network
add area=backbone network=1.1.1.1/32
add area=backbone network=192.168.10.0/30
add area=backbone network=192.168.20.0/30

/mpls ldp
set enabled=yes lsr-id=1.1.1.1 transport-address=1.1.1.1
/mpls ldp interface
add interface=ether2


R2

/ip address
add address=1.1.1.2 interface=lo network=1.1.1.2
add address=192.168.20.2/30 interface=ether2 network=192.168.20.0
add address=192.168.30.1/30 interface=ether3 network=192.168.30.0

/interface bridge
add name=lo protocol-mode=none

/routing ospf instance
set [ find default=yes ] router-id=1.1.1.2
/routing ospf network
add area=backbone network=1.1.1.2/32
add area=backbone network=192.168.20.0/30
add area=backbone network=192.168.30.0/30

/mpls ldp
set enabled=yes lsr-id=1.1.1.2 transport-address=1.1.1.2
/mpls ldp interface
add interface=ether2
add interface=ether3


R3

/ip address
add address=192.168.30.2/30 interface=ether3 network=192.168.30.0
add address=1.1.1.3 interface=lo network=1.1.1.3
add address=192.168.40.1/30 interface=ether4 network=192.168.40.0


/interface bridge
add name=lo protocol-mode=none


/routing ospf instance
set [ find default=yes ] router-id=1.1.1.3
/routing ospf network
add area=backbone network=1.1.1.3/32
add area=backbone network=192.168.30.0/30
add area=backbone network=192.168.40.0/30

/mpls ldp
set enabled=yes lsr-id=1.1.1.3 transport-address=1.1.1.3
/mpls ldp interface
add interface=ether3


Apabila berhasil saat kita traceroute muncul status label dari MPLS

Kita traceroute dari R1 ke R3 menggunakan interface loopback nya R3 yaitu 1.1.1.3


Sebalik nya kita traceroute dari R3 ke R1 menggunakan interface loopback R1 yaitu 1.1.1.1




Semoga Bermanfaat
Penulis  : Een Pahlefi,S.Kom

Subscribe to receive free email updates: