Routing OSPF Dasar

Kalo kemarin saya menulis tentang configurasi dasar rip sekarang saya akan menulis tentang OSPF, berbeda dengan RIP, OSPF memerlukan interface loopback agar bekerja dengan maksimal..
Secara umum OSPF sendiri terbagi 2 tipe yaitu :
1. Single Area
2. Multi Area

Yang akan saya bagikan dibawah ini adalah configurasi Single Area, baik lah langsung saja..

R1

/interface bridge
add name=lo protocol-mode=none


/ip address
add address=192.168.5.1/30 interface=ether5 network=192.168.5.0
add address=192.168.10.1/30 interface=ether1 network=192.168.10.0
add address=192.168.20.1/30 interface=ether2 network=192.168.20.0
add address=1.1.1.1 interface=lo network=1.1.1.1


/routing ospf instance
set [ find default=yes ] router-id=1.1.1.1
/routing ospf network
add area=backbone network=1.1.1.1/32
add area=backbone network=192.168.10.0/30
add area=backbone network=192.168.20.0/30


R2

/interface bridge
add name=lo protocol-mode=none

/ip address
add address=1.1.1.2 interface=bridge1 network=1.1.1.2
add address=192.168.20.2/30 interface=ether2 network=192.168.20.0
add address=192.168.100.1/24 interface=wlan1 network=192.168.100.0
add address=192.168.30.1/30 interface=ether3 network=192.168.30.0

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no mode=ap-bridge ssid=R2-OSPF

/routing ospf instance
set [ find default=yes ] router-id=1.1.1.2
/routing ospf network
add area=backbone network=1.1.1.2/32
add area=backbone network=192.168.20.0/30
add area=backbone network=192.168.100.0/24
add area=backbone network=192.168.30.0/30

/ip route
add distance=1 gateway=192.168.20.1


Kesimpulan nya

R1 mempunyai network
192.168.5.1/30
192.168.10.1/30
192.168.20.1/30
1.1.1.1/32

dan saling bertukar table routing menggunakan routing protokol OSPF dengan

R2 yang mempunyai network
1.1.1.2/32
192.168.20.2/30
192.168.100.1/24
192.168.30.1/30

Catatan : /32 merupakan interface loopback



Subscribe to receive free email updates: