Metode Ketuk Pintu di RouterOS

Salah satu mengamankan router ialah dengan menggunakan metode port knocking, atau yang bahasa sederhana nya, ketuk pintu dulu, kemudian baru pintu dibuka..

Nah dirouter os, kita bisa mengimplementasikan itu, digambar saya menyiapkan
1. 2 Buah komputer yang siap ingin mengakses winbox.





/ip firewall filter
add action=add-src-to-address-list address-list=ping address-list-timeout=none-dynamic chain=input protocol=icmp
add action=drop chain=input dst-port=8291 protocol=tcp src-address-list=!ping

seperti kita ketahui, port untuk mengakses winbox berjalan di protokol TCP dengan port 8291.
secara default, semua yang datang dari mana saja, dan ip apapun kita akan drop, tentu yang mengeksekusi nya adalah script

add action=drop chain=input dst-port=8291 protocol=tcp src-address-list=!ping

artinya, siapapun tidak akan bisa mengakses winbox, selanjutnya kita ketuk pintu dulu router nya, dengan cara mengirimkan paket ping menuju ip router.


ketika kita mengirimkan paket ping, maka secara langsung, ip komputer kita akan di tampung di address-list dengan nama address-list "ping"
yang mengekseskusi itu adalah script 

add action=add-src-to-address-list address-list=ping address-list-timeout=none-dynamic chain=input protocol=icmp

dengan begitu baru kemudian, secara otomatis, port 8291 akan listening, dan tidak akan terfilter oleh rule 
add action=drop chain=input dst-port=8291 protocol=tcp src-address-list=!ping

coba perhatikan ada tanda seru ! di bagian src-address-list...

Semoga Bermanfaat
penulis : Een Pahlefi,S.Kom

Subscribe to receive free email updates: