Pembahasan UKK TKJ 2016 2017 Paket 3

NFORMASI IP ADDRESS GATEWAY YANG DIBERIKAN ISP
SUBNETMASK : 255.255.255.0

INFORMASI IP ADDRESS ROUTER MIKROTIK
ETHER1 : 192.168.1.254
SUBNETMASK : 255.255.255.0

ETHER2 : 192.168.100.1
SUBNETMASK : 255.255.255.0

WLAN1 : 192.168.200.1
SUBNETMASK : 255.255.255.0


Kita configurasi nama interface (sesuaikan dengan router anda)
--------------------------------------------------------------------------------------------------------------------------
/interface ethernet
set [ find default-name=ether1 ] comment=ether1-internet
set [ find default-name=ether2 ] comment=ether2-switch

/interface wireless
set [ find default-name=wlan0 ] comment=wireless-wifi
---------------------------------------------------------------------------------------------------------------------------

Kita configurasi ip address untuk masing masing interface
-------------------------------------------------------------------------
/ip address
add address=192.168.1.254/24 interface=ether1 network=192.168.1.0
add address=192.168.100.1/24 interface=ether2 network=192.168.100.0
add address=192.168.200.1/24 interface=wlan1 network=192.168.200.0
-------------------------------------------------------------------------

Kita configurasi dns
-------------------------------------------------------------------------
/ip dns
set allow-remote-requests=yes servers=118.98.44.10,118.98.44.100
-------------------------------------------------------------------------

Kita configurasi default route
-------------------------------------------------------------------------
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.254
------------------------------------------------------------------------------

Kita configurasi nat, agar jaringan ether2 dan wlan0 dapat mengakses internet
------------------------------------------------------------------------------
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
-------------------------------------------------------------------------

Kita configurasi firewall di table filter, agar memblokir http://youtube yang datang dari ether2
------------------------------------------------------------------------------
/ip firewall filter
add action=drop chain=forward content=youtube.com in-interface=ether2 protocol=tcp
-------------------------------------------------------------------------

Kita configurasi nama SSID (nama-pemancar-wifi)
-------------------------------------------------------------------------
/interface wireless
set [ find default-name=wlan0 ] band=2ghz-onlyn disabled=no frequency=2437 mode=ap-bridge ssid=nama_peserta@Hotspot wireless-protocol=802.11


-------------------------------------------------------------------------------------------------
Configurasi hotspot ada 2 cara
1. Cara pertama ialah dengan menggunakan cara cepat dengan menggunakan setup (otomatis)
2. Cara kedua ialah dengan cara manual config satu persatu

-------------------------------------------------------------------------------------------------
Silahkan sesuaikan dengan kemampuan anda
-------------------------------------------------------------------------------------------------

Cara pertama (cara cepat) configurasi hotspot
-----------------------------------------------------------------------------------------------------------------------------------------------------------
ip hotspot setup
Select interface to run HotSpot on

hotspot interface: wlan0
Set HotSpot address for interface

local address of network: 192.168.200.1/24
masquerade network: no
Set pool for HotSpot addresses

address pool of network: 192.168.200.2-192.168.200.100
Select hotspot SSL certificate

select certificate: no                    
Select SMTP server

ip address of smtp server: 0.0.0.0
Setup DNS configuration

dns servers: 118.98.44.10,118.98.44.100
DNS name of local hotspot server

dns name: sekolah.sch.id
Create local hotspot user

name of local hotspot user: admin
password for the user: admin

------------------------------------------------------------------------------------------------

Membuat profile guru dan profile siswa (masing - masing saya batasi 20 user saja)
Membuat profile siswa (masing - masing saya batasi 10 user saja)
------------------------------------------------------------------------------------
/ip hotspot user profile
add name=guru shared-users=20 transparent-proxy=yes
add name=siswa rate-limit=256k/256k shared-users=10 transparent-proxy=yes
------------------------------------------------------------------------------------

Membuat user guru dan siswa
---------------------------------------------------------------
/ip hotspot user
add name=guru password=guru profile=guru
add name=siswa password=siswa profile=siswa
---------------------------------------------------------------

Kita configurasi agar semua pengguna hotspot yang belum login, dapat membuka website sebagai berikut
1. http://bsnp-indonesia.org
2. http://mikrotik.co.id
----------------------------------------------------------------
/ip hotspot walled-garden
add dst-host=*bsnp-indonesia.org
add dst-host=*mikrotik.co.id
----------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------------------------------------------------------


Cara kedua (cara manual) configurasi hotspot
----------------------------------------------------------------------------------------------------------------------------------------------------------
/ip dns static
add address=192.168.200.1 name=sekolah.sch.id

---------------------BAGIAN-CONFIGURASI-DHCP-SERVER-WLAN0---------------------------------------------------
/ip pool
add name=dhcp-pool-wlan0 ranges=192.168.200.2-192.168.200.100

/ip dhcp-server
add address-pool=dhcp-pool-wlan0 disabled=no interface=wlan0 lease-time=1h name=dhcp-wlan0

/ip dhcp-server network
add address=192.168.200.0/24 comment="hotspot network" gateway=192.168.200.1
-----------------------------------------------------------------------------------------------

/ip hotspot profile
add dns-name=sekolah.sch.id hotspot-address=192.168.200.1 login-by=http-chap name=hsprof1
/ip hotspot
add address-pool=dhcp-pool-wlan0 disabled=no interface=wlan0 name=hotspot1 profile=hsprof1
/ip hotspot user
add name=admin password=admin


Membuat profile guru dan profile siswa (masing - masing saya batasi 20 user saja)
Membuat profile siswa (masing - masing saya batasi 10 user saja)
------------------------------------------------------------------------------------
/ip hotspot user profile
add name=guru shared-users=20 transparent-proxy=yes
add name=siswa rate-limit=256k/256k shared-users=10 transparent-proxy=yes
------------------------------------------------------------------------------------

Membuat user guru dan siswa
---------------------------------------------------------------
/ip hotspot user
add name=guru password=guru profile=guru
add name=siswa password=siswa profile=siswa
---------------------------------------------------------------

Kita configurasi agar semua pengguna hotspot yang belum login, dapat membuka website sebagai berikut
1. http://bsnp-indonesia.org
2. http://mikrotik.co.id
----------------------------------------------------------------
/ip hotspot walled-garden
add dst-host=*bsnp-indonesia.org
add dst-host=*mikrotik.co.id

BAGIAN-CONFIGURASI-MENGUBAH-HALAMAN-HOTSPOT
1. Aplikasi winscp > https://winscp.net/download/WinSCP-5.9.3-Portable.zip

2. Pastikan semua service port 21/22 dalam keadaan open port > bisa dilihat di gambar "ip-service.png" (disertakan dalam folder)
3. Buka aplikasi winscp > bisa di lihat di gambar "winscp-login.png" (disertakan dalam folder)
4. Setelah berhasil login, buka folder hotspot , kemudian buka file login.html , dan tambahkan baris berikuti setelah tag <body> (disertakan dalam folder)
---------------------------------------------------------------------
<h1>SELAMAT DATANG DIHOTSPOT SEKOLAH SMKN5 BANJARMASIN</h1>
---------------------------------------------------------------------
5. Kemudian simpan dengan dengan cara ctrl + s pada keyboard

Lampiran Mengedit Login Page MikroTik









Penulis : Een Pahlefi,S.Kom

Subscribe to receive free email updates: