VPN PPTP ke Server Pribadi

Jumpa lagi dengan saya Een Pahlefi.. Disela sela ngerjain revisi skripsi, masih aja gua sempet sempetin nulis hobi gua di bidang jaringan...

Jadi ceritanya gua punya server, tapi lokasi server nya di sekolah... biar enak gitu maintenance nya..

Sebelum kita ke praktek, ada baik nya kita tau dulu apa itu VPN, ya.. VPN merupakan Virtual Private Network. yang berfungsi mengakses jaringan secara pribadi melewat internet, jadi intinya walaupun kita berada dirumah, kita seolah olah berada dalam jaringan tersebut. Kalian bisa perhatiin kok gambar disamping.. bisa di pahami ya.. 

Metode untuk melakukan VPN ada beberapa cara nih diantaranya :
1. PPTP (Point to Point Tunnel Protocol)
2. L2TP (Layer 2 Tunnel Protocol)
3. SSTP (Secure Socket Tunneling Protocol)
4. OpenVPN
5. dan masih banyak lagi..

Gua asumsikan jaringan lo sudah sesuai dengan topologi diatas..
IP Server Moodle : 192.168.7.2/29

Kita configurasi router mikrotik nya.
#Enable PPTP Server
/interface pptp-server server
set authentication=pap,chap,mschap1,mschap2 enabled=yes
#IP Address
ip address
add address=192.168.7.1/29 interface=vlan19-ether19-Ubuntu-DNS network=192.168.7.0
#Username dan Password VPN
/ppp secret
add local-address=192.168.7.1 name=eenpahlefi-network password=network-eenpahlefi remote-address=192.168.7.4 service=pptp
Configuring Windows 10
#Create Connection VPN











#Insert Username and Password











#Create Successfull











#Choose Connect











#Status Connected











Sampai disini kita sudah berhasil membuat koneksi VPN dengan PPTP..
Ups, jangan lupa untuk menghilangkan Use default gateway on remote network , yang dapat mengakibatkan kita memakai koneksi internet di server kita.. akibatnya ip public kita sendiri berubah menjadi ip public server kita tersebut. tentu ini akan membuat paket kita muter muter.
#unchecklist Use default gateway on remote network

Subscribe to receive free email updates: